编译 edk2-stable202111

EDK2 稳定版代码已经更新到 edk2-stable202111 了,总觉得有一点新鲜感,就下载了一份代码来编译。这次是在release页面下载的,我才发现之前需要使用 git submodule update --init 命令下载的包在这个页面都是有上传的,也就是直接下载,然后再放到edk2代码内就可以了,无需再用git联网下载,想当初因为网络的关系,花费了不少时间。。。

把源码下载完后编译,无法通过,最让人头疼的是没有任何反应,也没任何出错的提示....

冷静分析了下,可能是VS2015不再支持了或者我安装得有问题,前者可能性比较小,如果是后者问题,那我得重新安装VS2015,非常麻烦,于是这两个因素都跳过了,把矛头指向了Python。因为我一直用UDK2018,只需要PY2.7,所以没有安装更高版本的,会不会是PY版本过低导致的?抱着试一试的态度,安装了个3.85的版本,重新编译,居然正常了!

需要吐槽一下的是,官方的文档万年不更新,也是误导了我,因为写着Python2.7.10以后的版本都是支持的,我用的2.7.15就没多想。

最后再强调一下,如果要编译最新的EDK2代码,务必要把Python升级到3.7以上版本!

edk2-stable202111 下载

链接:https://wwa.lanzouo.com/b0dlk8iyf

密码:7yah

官方页面:https://github.com/tianocore/edk2/releases

版权声明:
作者:bin
链接:https://ay123.net/mystudy/uefi/1273/
来源:爱影博客
文章版权归作者所有,未经允许请勿转载。

THE END
分享
二维码
< <上一篇
下一篇>>
文章目录
关闭
目 录